(Lack of) Pump Failure Detection

Interesting thing happened today.

I had to run a quick engrave on something for my wife, so I booted my Glowforge into the factory firmware so I could use the GFUI.

While running the engrave, I noticed large pockets of air inside the tube. Normally, any bubbles are rare and they are whisked away quickly. Something was clearly amiss.

I opened the unit to find that the water pump was not running. I consoled in and found the pump was set to on. I wiggled the connector on the board, and the pump came back to life and all the air was purged from the tube.

Once upon a time, I recall the firmware testing for coolant flow. It did this by having two temp sensors in the fluid path with a heater between them. By energizing the heater, the firmware could detect that the coolant was cooler upstream from the heater, and warmer downstream.

I’m not sure if this still happens. I’m going to deliberately disconnect the pump one of these days to test…

One thing is for certain, they are definitely not checking for coolant flow while the unit is running a job. This would explain why people have had the dreaded catastrophic tube explosions.

The same would have likely happened to me had I let it run any longer.

Out of the loop for another 999 years, so I haven’t heard about those but even cheap Chinese PSUs have a input for the water flow detector so you can’t turn on the laser if it isn’t running.

Well, I just booted with the factory firmware and the water pump unplugged.

It doesn’t care.

Ready to “print”.

I know for a fact that this is not how previous firmware images worked. It used to go through a multiple phase process to test the coolant flow.

Previous log files on boot:

2019-02-19_02:54:31.67628        171  INFO: coolant: initialized
2019-02-19_02:54:31.69836        190  INFO: coolant_flow_controller_peripheral: Entering pump state 2
2019-02-19_02:54:31.69837        190  INFO: coolant_flow_controller_peripheral: Pump off
2019-02-19_02:54:31.69838        191 DEBUG: coolant_temp_monitor_data_logging_interval: setting to 100 ms
2019-02-19_02:54:31.69839        191 DEBUG: coolant_temp_monitor_timer: setting to 1000 ms
2019-02-19_02:54:31.69839        191 DEBUG: coolant_temp_update_timer: setting to 100 ms
2019-02-19_02:54:31.69840        191 DEBUG: coolant_flow_controller_data_logging_interval: setting to 100 ms
2019-02-19_02:54:31.69843        193  INFO: coolant: started (TID=610)

From a previous log file after a print:

2017-10-15_18:28:21.87301      18330  INFO: coolant: upstream=22.36, downstream=22.19, offset=0.17

Now, it seems like it just reads the temp and that’s it:

2020-03-01_02:38:06.63996        222  INFO: coolant: initialized
2020-03-01_02:38:06.64538        233 DEBUG: coolant_temp_monitor_data_logging_interval: setting to 100 ms
2020-03-01_02:38:06.65245        235 DEBUG: coolant_temp_update_timer: setting to 100 ms
2020-03-01_02:38:06.65247        235 DEBUG: coolant_temp_monitor_timer: setting to 1000 ms
2020-03-01_02:38:06.65778        243  INFO: coolant: started (TID=614)

And the heater PWM is set to 0. The heater PWM is what heats the water to detect the flow.

My device is running the latest firmware version 1.11.3-7

1 Like

They removed the “pump state” mechanism somewhere between versions 1.9.2-63 and 1.10.1-73 which was released in March 2019.

v1.9.2-63:

v1.10.1-73:

Now, that’s not to say they didn’t replace it with a different mechanism. However, whatever that mechanism is clearly doesn’t work.

Others can confirm this by simply unplugging the water pump from the circuit board on the left, and powering up your unit. It should not tell you it is ready to “print” when the pump isn’t functional, and certainly not allow you to run the unit.

This is problematic.

Nightmare. They can downgrade your machine from safe to unsafe behind your back. Either it was a mistake or the sensor is unreliable and they decided not to use it and hope the pump works. Either way I am glad I didn’t get one.

1 Like

Also the cheap solution is fool proof in that it doesn’t rely on firmware.

@ScottW514, thanks for looking in to this.

I’d like to see this addressed on the official forum. Not sure I am brave enough to ask about it, though. :wink:

If I had confirmation from someone else that they can disconnect the pump and still kick off a job (manually lifting the lid to interrupt it as soon as the laser first fired to keep from doing any damage), I’d venture a post on the official support forum myself.

Mine has been “worked on” quite a bit and, while I highly doubt that is the cause, I’d like to make doubly sure that it doesn’t have something to do with it.

I wouldn’t expect a real response form Glowforge, though. More likely than not it would be something about how they have multiple safe guards in place, but they can’t comment on them or give any specifics because its super secret stuff.

1 Like

That sounds like a good conservative approach.

Ain’t that the truth!

They might also use the phrase “We have nothing to share on that”. They might even have that trademarked.